Ninja 400 Riders Forum banner

1 - 20 of 25 Posts

·
Registered
Joined
·
5,656 Posts
Discussion Starter #1 (Edited)
1. Turn your ignition on
2. Check your top display is on ODO and not Trip A or B
3. Hold both buttons in for more than 2 seconds
4. The error code will now show where your odo mileage was previously (see attached pic)
5. Turn ignition off to return screen to normal function.

P1000080.JPG

Here is the list of error codes:

11 Main throttle sensor malfunction, wiring open or short.
12 Intake air pressure sensor malfunction, wiring open or short.
13 Intake air temperature sensor malfunction, wiring open or short.
14 Water temperature sensor malfunction, wiring open or short.
21 Crankshaft sensor malfunction, wiring open or short
24 Rear wheel rotation sensor malfunction, wiring open or short.
25 Gear position sensor malfunction, wiring open or short.
31 Vehicle-down sensor malfunction, wiring open or short.
32 Sub throttle sensor malfunction, wiring open or short.
33 Oxygen sensor malfunction or Inactivate, wiring open or short.
39 ECU communication error
41 Fuel injector #1 malfunction, wiring open or short.
42 Fuel injector #2 malfunction, wiring open or short.
51 Stick coil #1 malfunction, wiring open or short.
52 Stick coil #2 malfunction, wiring open or short.
56 Radiator fan relay malfunction, wiring open or short.
62 Subthrottle valve actuator malfunction, wiring open or short.
64 Air switching valve malfunction, wiring open or short.
67 Oxygen sensor heater malfunction, wiring open or short.
94 Fuel supply system malfunction
3A Purge valve malfunction, wiring open or short (Equipped Models)

So you can see that my error (#25) is Gear position sensor malfunction. This is because I changed my final drive ratio to outside of the operating perimeters of the sensor by fitting a 38 tooth rear sprocket. It didnt affect the running of the bike in any way other than the engine warning light coming on and the gear position screen flashing two horizontal lines.

* Props to @rde09 & @xplorguy for finding this information when I was having my issue away from home.
 

·
Registered
Joined
·
244 Posts
Have added a credit to my original post. Was just trying to present our findings in a concise post.
Appreciate your efforts. :)
Sorry, I was just having fun. xplorguy did all the leg work, I just copy and pasted, and you were the one poster that could refine it for the Ninja 400 (since you were the first to suffer an CEL) :angel:
 

·
Registered
Joined
·
764 Posts
ECU flash kit allows for insertion of custom sprockets, aka just insert the number of teeth of rear and front sprocket and flash :) might buy me a kit hehe
 

·
Registered
Joined
·
5,656 Posts
Discussion Starter #6
ECU flash kit allows for insertion of custom sprockets, aka just insert the number of teeth of rear and front sprocket and flash :) might buy me a kit hehe
What brand is the kit/software package?
The guy who is doing mine uses the Woolich software, not sure if it has this function or not.
My error code is gone again now and the gear indicator is working. Weird. :confused:
 

·
Registered
Joined
·
764 Posts
What brand is the kit/software package?
The guy who is doing mine uses the Woolich software, not sure if it has this function or not.
My error code is gone again now and the gear indicator is working. Weird. :confused:
the flash tune kit, eitherway I think the woolich tune will work as well, what guy is doing your tune and how much?
 

·
Registered
Joined
·
5,656 Posts
Discussion Starter #10
let me know if the AFR is more lean or rich stock when he throws it on the dyno, cheers :)
OK, by then I will have the Scorpion slip-on on and maybe aftermarket filter, boats out on that one. Seems there is mixed opinion on whether there is any gains to be had. Will ask the tuner.
 

·
Registered
Joined
·
764 Posts
OK, by then I will have the Scorpion slip-on on and maybe aftermarket filter, boats out on that one. Seems there is mixed opinion on whether there is any gains to be had. Will ask the tuner.
nice :) maybe ask him to save the tune as a map and upload it here for other aussie/nz members to apply to there bikes, especially the ones who de-cat there own exhausts ;)
 

·
Registered
Joined
·
18 Posts
I just installed a slipon muffler and at first start the check engine light was on. The trouble code is 24. Is that coincidence? There doesn't seem to be a way to reset or turnoff the check engine light. Any thoughts?
 

·
Registered
Joined
·
744 Posts
I just installed a slipon muffler and at first start the check engine light was on. The trouble code is 24. Is that coincidence? There doesn't seem to be a way to reset or turnoff the check engine light. Any thoughts?
Trouble code 24: rear wheel position sensor for ABS equipped bikes. How is that related to adding a slip-on?

Check the rear wheel ABS sensor is not damaged. Kawasaki did a stupid job of leaving the sensor wire dangling out like that waiting for it to get ripped off. If the sensor and wire appears to be intact you can try erasing the DTC code.

What I would do is take it to a certified Kawi dealer and have them look at it under warranty. It may be a simple software patch.
 
  • Like
Reactions: Kiwi Rider

·
Registered
Joined
·
18 Posts
Yeah right, that's what I was thinking slipon totally unrelated and just a coincidence or maybe the trouble codes were not exactly correct I was thinking. I started today for a short trip and now the speedo is not working, trouble codes looking to be correct since I still have a 24 on the trouble code.

The bike has less than 350 miles. It was just a bizarre coincidence that the first time I started it to hear it after putting on the slipon it threw that check engine light and 24 code. The bike had 12 miles on it when I bought it and a loose chain. I tightened up the chain within the first 100 miles and saw some wire running under the swing arm and thought how lame that was, just as you've said. I had to re-position the stand to not pinch the wire. That is likely the problem, very minor but just a badly designed setup that will get pinched again unless special attention is given to it.

I've got the blue ninja 400 so it's not even abs. The back wheel has that notched disc like it's an abs model. The front doesn't of course and there's no sensor up front. It seems less than ideal to have abs artifacts at the back wheel for the non abs model.
 

·
Registered
Joined
·
744 Posts
Yes dual function, thanks Kiwi.
 

·
Registered
Joined
·
6 Posts
Can't Access Error Code

Does anybody know whether the error codes are stored in volatile or non-volatile memory?

I've followed the instructions (ODO - check; press both buttons - check),but all that I get is the clock update function.

Bike has PC V with Autotune, full exhaust, PAIR blockoff with dongle, sidestand cutout dongle and left hand control removal dongle. Radiator fan simply removed (no dongle). After an unremarkable left side low-side it has developed an intermittent engine cutout. If I coast to a stop it will readily restart, but this is not conducive to good lap times or finishing position! First experienced before the sidestand and hand control dongles were installed. Engine must be fairly hot, and it is always/usually in 4th gear.

Had a lithium battery installed, and at the recommendation of my sponsoring dealership, I have tried a standard battery, hence my volatile/non-volatile question.

I will be calling Spears and my dealership in the morning, but any input before then would be appreciated.
 

·
Registered
Joined
·
2 Posts
I have problem with code 67. After reset the ecu the engine light still pop out. And the error code is 67. What should i do for this error code.
 

·
Super Moderator
Joined
·
1,310 Posts
I have problem with code 67. After reset the ecu the engine light still pop out. And the error code is 67. What should i do for this error code.
Sounds like an Oxygen sensor issue. if you don't have the manual, I think Yarddog can send you a copy
 

·
Registered
Joined
·
2 Posts
Sounds like an Oxygen sensor issue. if you don't have the manual, I think Yarddog can send you a copy
actually there is 2 error code. 33 and 67. but after i done FID tuning code 33 disappear. only 67 pop out. anyone have sensor wiring diagram. i want to check the heater wire.
 
1 - 20 of 25 Posts
Top