Ninja 400 Riders Forum banner

1 - 20 of 24 Posts

·
Registered
Joined
·
501 Posts
Discussion Starter #1 (Edited)
Hey guys,


Having my baby for almost 3 months now. Oil change has been done at the dealership at 999km (exact :grin:) using Motul 5100 15w50 2L.


Currently standing at 1960~ km.


This saturday while being at the gas station somebody told me that oil is leaking out of the fill cap, I gave a look and it was indeed leaking (or at least leaked, was pretty dry). Came home after the ride and cleaned it off. Just came home after 150km trip now, gave it a look... and it was leaking again.


I've really babied the bike during the initial break in, and kept it pretty light until 1300-1400km. Since then I just started rolling.. normal riding and using its full power when needed..

My riding is really calm, I dont like to rev it high at all and most defenitly not for long, shifiting at 6k~.


Attaching photos. Also, as you might know there's a blown gasket issue, gave a look to the front of the engine as well and there was some dirt (probably oil..?) on the side of it. cleaned it and attached photos too.


The 160km today was a really random ride...climate here is pretty hot 30c which is about 88f.


Is this a hint of things to come? Im pretty afraid..
 

Attachments

·
Registered
Joined
·
377 Posts
Hey guys,


Having my baby for almost 3 months now. Oil change has been done at the dealership at 999km (exact :grin:) using Motul 5100 15w50 2L.


Currently standing at 1960~ km.


This saturday while being at the gas station somebody told me that oil is leaking out of the fill cap, I gave a look and it was indeed leaking (or at least leaked, was pretty dry). Came home after the ride and cleaned it off. Just came home after 150km trip now, gave it a look... and it was leaking again.


I've really babied the bike during the initial break in, and kept it pretty light until 1300-1400km. Since then I just started rolling.. normal riding and using its full power when needed..

My riding is really calm, I dont like to rev it high at all and most defenitly not for long, shifiting at 6k~.


Attaching photos. Also, as you might know there's a blown gasket issue, gave a look to the front of the engine as well and there was some dirt (probably oil..?) on the side of it. cleaned it and attached photos too.


The 160km today was a really random ride...climate here is pretty hot 30c which is about 88f.


Is this a hint of things to come? Im pretty afraid..
Nah, go pick up an oring. It probably got pinched.
 

·
Registered
Joined
·
179 Posts
Well after writing this thread i've opened the cap myself and refitted the o ring... 150km after I didnt have it again for now. Guess the morons at the dealership couldn't close it properly either..
I haven’t actually taken the o-ring off and reseated it but I’m having the same issue, keep getting an oil leak from the filler cap. Haven’t checked to see if there’s a leak on the engine though...
 

·
Registered
Joined
·
501 Posts
Discussion Starter #8
I haven’t actually taken the o-ring off and reseated it but I’m having the same issue, keep getting an oil leak from the filler cap. Haven’t checked to see if there’s a leak on the engine though...

Hi,


I just put a good thick layer of engine oil on the cap and the threads on the engine casing where the cap sits and close it good, same as you do with an oil filter. I did it for the first time less than a month ago, I think that's the best way. Up until that time I always was just closing it dry, probably where the mistake have been.
 

·
Registered
Joined
·
179 Posts
I haven’t actually taken the o-ring off and reseated it but I’m having the same issue, keep getting an oil leak from the filler cap. Haven’t checked to see if there’s a leak on the engine though...

Hi,


I just put a good thick layer of engine oil on the cap and the threads on the engine casing where the cap sits and close it good, same as you do with an oil filter. I did it for the first time less than a month ago, I think that's the best way. Up until that time I always was just closing it dry, probably where the mistake have been.
There is oil on the o-ring and threads, I’m almost wondering if the dealer put to much oil in it
 

·
Registered
Joined
·
1,578 Posts
There is oil on the o-ring and threads, I’m almost wondering if the dealer put to much oil in it

If the cap is tightened properly it shouldn't leak out even if there's more oil than there should be. If the o-ring is there and it's not damaged, just tighten it up and it should be good.
 

·
Registered
Joined
·
1,393 Posts
Thanks for this thread! I'm coming up on my 600m service and will be taking it in. Glad to know what to do if mine starts to leak...

My hope is that the mechs will allow me to sit in and watch them do the service (since the previous rep told me that I could wait for it). I'll be sure to bring some yummy deliciousness for the guys (like donuts and cookies and beef jerky) in my backpack when I bring it in. :devil::devil::devil::smile_big:

Think they'll let me watch them work on it??? :grin:
 

·
Registered
Joined
·
1,578 Posts
Generally techs don't like it when customers are there watching. I don't know of many people that like to be watched while they're working, unless the job requires it. But with that said, I think Kiwi's right. They will probably make an exception for a female bringing food! :D



That's why I miss my old local Ducati dealership. Those guys were all awesome, I used to go there and just BS with them whenever I could. They didn't want a bunch of random people in the shop, but they didn't care if some of us "regulars" would go in and hang out. I've even seen one guy that used to just take his bikes there and he would do the work himself lol...so he'd basically just use their shop and tools lol
 

·
Registered
Joined
·
805 Posts
Aluminum fill cap

I had no idea some were having issues with the fill cap. I changed mines to a sexy blue aluminum one and the drain bolt as well. I had no issues with either. But my home track requires that both be safety wired. So both have the holes pre drilled.
 

Attachments

·
Registered
Joined
·
5,630 Posts
... Generally techs don't like it when customers are there watching. I don't know of many people that like to be watched while they're working, unless the job requires it.
It's going the same way here too now unfortunately. Health and safety and all that malarkey.
The guy who did my ECU flash is one of the good ones who still lets you in the dyno room which I was stoked about. Learn't so much.
 

·
Registered
Joined
·
1,578 Posts
I had no idea some were having issues with the fill cap. I changed mines to a sexy blue aluminum one and the drain bolt as well. I had no issues with either. But my home track requires that both be safety wired. So both have the holes pre drilled.

Is that the spring from Spears or something you procured on your own? Any chance you could give me the diameter and length (free length) of it?



It's going the same way here too now unfortunately. Health and safety and all that malarkey.
The guy who did my ECU flash is one of the good ones who still lets you in the dyno room which I was stoked about. Learn't so much.

I'll be taking mine to a shop owned by a fellow racer in the next 2 or 3 weeks for some dyno runs. Just want to see what it's putting out as is now. I hope he can do it while I'm there because I'd like to watch.
 

·
Registered
Joined
·
805 Posts
Spears spring

Is that the spring from Spears or something you procured on your own? Any chance you could give me the diameter and length (free length) of it?

Yes I got the clutch arm spring from Spears racing. Haven’t ridden the bike with it yet but it does seem to snap back strongly!:clap:
 

·
Registered
Joined
·
144 Posts
My question is, why would you run 15W50 when Kawi recommends 10w40 for temps up to 104*F? Thicker oil does nothing but rob power, and wear components faster when it's not required... I suspect that thicker oil causes increased crankcase pressure and could contribute to blowing out seals. I've done two oil changes on mine and haven't had a leak. I run 10w40 in Oklahoma and it regularly tickles 100-110* in the summer. Only thing I'd run that thick of oil in would be an air cooled bike. I'm not trying to tell you what to do but that seems like thick oil and could be a contributor to your issue.
 
1 - 20 of 24 Posts
Top