Ninja 400 Riders Forum banner

341 - 347 of 347 Posts

·
Registered
Joined
·
9 Posts
You have an error code 25. I posted about this myself, check it it out. Forgot who mentioned it but he said don't sweat it. So decided to just ride the thing, went for long rides with friends. Like I mentioned all functions cleared....just for awhile then cel and gear indicator malfunctioned once again. Finally I shorted the clutch switch and again ignored the problem, went for normal rides knowing eventually it would clear which it did. So my Z400 is in perfect running order and I'm a happy rider.
Ok sounds like a plan, I'll try a few weekend rides and see if it clears.
 

·
Registered
Joined
·
9 Posts
So today I still have CEL on yay for me 😀 but I did install a 38t rear sprocket for longer legs and less rpm on the highway. It's way more relaxed bike now.
Providing the indicator comes back on I'll be a happy chappy.

Also being a bike with only 300klm on it 1+ 3- dosent need anything links taken out.FYI if anyone is interested
 

·
Registered
Joined
·
5,269 Posts
Discussion Starter #344
So today I still have CEL on yay for me 😀 but I did install a 38t rear sprocket for longer legs and less rpm on the highway. It's way more relaxed bike now.
Providing the indicator comes back on I'll be a happy chappy.

Also being a bike with only 300klm on it 1+ 3- dosent need anything links taken out.FYI if anyone is interested
I'm running a 38T as well and with 15K on the chain it's still got adjustment left.
 

·
Registered
Joined
·
9 Posts
I'm 14/38 so stock front sprocket. Can you take off in first gear without slipping the clutch on 15/38?
Yeah seem to be ok. Didn't really notices myself slipping the clutch anymore or less to get moving.

But most of my riding is open roads

I'll know more on the weekend when I ride in town how it goes.

Also the gear commander chart isn't really that accurate when it comes to gearing and rpm changes didn't reduced the rpms as much as the chart indicated.
 
341 - 347 of 347 Posts
Top