Ninja 400 Riders Forum banner

2022 Ninja 400 non ABS Fl fuse keeps blowing

188 Views 11 Replies 5 Participants Last post by  Flash Bantam
I need some help the Fl fuse keeps blowing on my bike. Anyone have an idea on what might cause this? I know how to work on the bikes but troubleshooting is not my best feature.
1 - 12 of 12 Posts
I need some help the Fl fuse keeps blowing on my bike. Anyone have an idea on what might cause this? I know how to work on the bikes but troubleshooting is not my best feature.
Does it pop the fuse when you turn the key on, when crank the bike, and give us a bit more information so we can better help evaluate the situation. 馃憤
  • Like
Reactions: 1
Does it pop the fuse when you turn the key on, when crank the bike, and give us a bit more information so we can better help evaluate the situation. 馃憤
When I cranked it鈥.new exhaust so thinking maybe I messed up a wire from the O2 sensor?
Always the first question to ask is what changed since when the bike was working...

Possibly try disconnecting the O2 sensor altogether -- you'll throw a code but than you can rule out that wiring...

Look for anything melted near the new exhaust...
  • Like
  • Helpful
Reactions: 4
When I cranked it鈥.new exhaust so thinking maybe I messed up a wire from the O2 sensor?
I doubt that changing to an exhaust whether it's a slip on or full exhaust would damage the O2 wiring.
So the fuse pops every time you crank it. 馃

Nothing else you've done electrically to the bike?
Have you checked your battery connections to make sure they're tight?

Maybe @Rich T might be able to shed some light on this also. 馃憤
  • Like
Reactions: 1
So when I was removing the O2 I was rushing and it ended up being the O2. I unplugged it and replaced the fuse and boom I鈥檓 back on 2s. I was being lazy and did not unplug the O2 like I should have done. I got the Kawasaki Brad O2 delete on the way to my house now.
  • Like
  • Haha
Reactions: 4
So when I was removing the O2 I was rushing and it ended up being the O2. I unplugged it and replaced the fuse and boom I鈥檓 back on 2s. I was being lazy and did not unplug the O2 like I should have done. I got the Kawasaki Brad O2 delete on the way to my house now.
Dude that's awesome. 馃槀馃憤
Hey we've all been there. 馃し馃徏鈥嶁檪锔忦煈
  • Like
Reactions: 1
Yep delete kit will be here next Wednesday. Thank you all for the help! This community seems legit.
  • Like
  • Love
Reactions: 3
So when I was removing the O2 I was rushing and it ended up being the O2. I unplugged it and replaced the fuse and boom I鈥檓 back on 2s. I was being lazy and did not unplug the O2 like I should have done. I got the Kawasaki Brad O2 delete on the way to my house now.
I'm using the kawasakibrad.com 02 Eliminator plug with great results. I have a full Musarri exhaust system. I also removed the Pair Valve and EVAP canister, his delete plugs work perfectly.
  • Helpful
Reactions: 1
1 - 12 of 12 Posts
Top